Introducing 14k Gold, read more on the blog.
Home » Shapeways » Official Announcements » Shapeways site update of December 1st 2010
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Shapeways site update of December 1st 2010 [message #21128] Wed, 01 December 2010 12:43 UTC Go to next message
avatar barrys  is currently offline barrys
Messages: 116
Registered: May 2010
Go to all my models
Senior Member
I work here
Hi all,

we had site update today that took a bit longer than usual, but all went well eventually.
We released the following features/bugfixes:

Fixed hanging default properties in creators We had the problem that the default text in the creators wouldn't change on some operating systems with the latest java version update and therefore couldnt order or save a creator. This is now fixed finally.

Store sorting directions The sorting directions like picerange from 'low to high' is now stored for every gallery you last visited.

The 3D viewer popup did not appear when a model wasn't printable.

It wasn't always clear that when you want to become a business user and already had a shop you have to contact customer support, so we added a text to inform the user when you try that.


Best regards,
Barry
Re: Shapeways site update of December 1st 2010 [message #21147 is a reply to message #21128 ] Wed, 01 December 2010 18:07 UTC Go to previous messageGo to next message
avatar virtox  is currently offline virtox
Messages: 1141
Registered: August 2008
Go to my shop
Senior Member
moderator
I do seem to be suffering from a glitch in the model pipeline..

This afternoon I updated an existing model with a zipped 500k stl.
The page showed the "is processing" a long time. (500k takes a while Wink)
Only got one email. (thanks for uploading)
When the message was gone, the model had not been updated, the version is still zero. And the volume also shows old values.

In the mean time I had uploaded two new low-poly stl's which went through instantly.

I have now uploaded two 500k stl files, unzipped, but as yet nothing to see.

Also tried the update again :
http://www.shapeways.com/model/165678/holey__l_.html?gid=ug4 834
Still processing too.
The update has worked this time., but the earlier uploaded 500k models have not made ti through yet.

I'm assuming there are multiple upload pipelines?
As they seem to overtake each other sometimes?



Cheers,

Stijn

[Updated on: Wed, 01 December 2010 18:38 UTC]


- Artist / Engineer / Designer / Shopowner / Volunteer / Moderator -
Re: Shapeways site update of December 1st 2010 [message #21153 is a reply to message #21147 ] Wed, 01 December 2010 20:05 UTC Go to previous messageGo to next message
avatar Magic  is currently offline Magic
Messages: 1115
Registered: August 2008
Go to my shop
Senior Member
Same thing here. My update is stuck...
I have the message:
Quote:

Your model is currently being processed, this takes approximately 5 to 15 minutes. In the meantime you will not be able to delete your model
for more than 30 min now...
My model is not very big though...
Re: Shapeways site update of December 1st 2010 [message #21154 is a reply to message #21153 ] Wed, 01 December 2010 20:20 UTC Go to previous messageGo to next message
avatar virtox  is currently offline virtox
Messages: 1141
Registered: August 2008
Go to my shop
Senior Member
moderator
Ok, things seem to be trickling through, after 3 hours one of the models made it. So I assume the second one will too, eventually.

The first model update took more than 6 hours, I assume the second attempt at update is still being checked..

So I guess it's just a busy upload day?

Could be useful if there were some sort of indicator on site, how busy the upload queue is?

[Updated on: Wed, 01 December 2010 20:31 UTC]


- Artist / Engineer / Designer / Shopowner / Volunteer / Moderator -
Re: Shapeways site update of December 1st 2010 [message #21155 is a reply to message #21128 ] Wed, 01 December 2010 20:33 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5115
Registered: September 2008
Go to my shop
Senior Member
I work here
I've noticed that it's fairly common for things to get backed up after updates. Probably working through the que up back log until it's up to full speed again.


The Mad Moder
michael@shapeways.com
Re: Shapeways site update of December 1st 2010 [message #21164 is a reply to message #21155 ] Wed, 01 December 2010 22:56 UTC Go to previous messageGo to next message
avatar Magic  is currently offline Magic
Messages: 1115
Registered: August 2008
Go to my shop
Senior Member
I took 3 hours for me too: but the update eventually occured.
I guess the updates are slowed down by all the people trying to do the 10,000th upload, right? Very Happy


So many things to design, so little time...
Re: Shapeways site update of December 1st 2010 [message #21179 is a reply to message #21164 ] Thu, 02 December 2010 10:38 UTC Go to previous messageGo to next message
avatar barrys  is currently offline barrys
Messages: 116
Registered: May 2010
Go to all my models
Senior Member
I work here
I looked into this, but seems it was not update related but simply a few models in the queue that cost a lot of calculation time. This could occur at any time.

We're looking into this to improve the upload time.
Re: Shapeways site update of December 1st 2010 [message #21180 is a reply to message #21179 ] Thu, 02 December 2010 10:55 UTC Go to previous messageGo to next message
avatar virtox  is currently offline virtox
Messages: 1141
Registered: August 2008
Go to my shop
Senior Member
moderator
Ok, thanks and sorry for the false alarm, I was in a hurry for a customer order..
And I got a bit confused because the order of model approval got shuffled.

Also, the (updated) model page gave a premature indication it was done (processing message disappeered several hours before I got the final "ok" email)

Me uploading several 500k models at the same time,
probably did not help with the queue speed Rolling Eyes

Still, some sort of queue monitor/message would seem ideal,
"50 models before yours, please hold" Smile

Perhaps just a few color codes : ( since the USA won't be using them anymore Razz)
green(quiet)
yellow(busy)
red(very busy)
black(down/clogged)

Cheers,

Stijn


- Artist / Engineer / Designer / Shopowner / Volunteer / Moderator -
Re: Shapeways site update of December 1st 2010 [message #21208 is a reply to message #21180 ] Thu, 02 December 2010 23:31 UTC Go to previous messageGo to next message
avatar GHP  is currently offline GHP
Messages: 118
Registered: October 2009
Go to my shop
Senior Member
Hi,

I'm now getting the error message "An unknown error occured" when I try to view "My Designs". I can still view them through my shop, however.

Thanks,
Gillian.
Re: Shapeways site update of December 1st 2010 [message #21219 is a reply to message #21208 ] Fri, 03 December 2010 06:19 UTC Go to previous messageGo to next message
avatar WelshDesigns  is currently offline WelshDesigns
Messages: 60
Registered: April 2010
Go to my shop
Member
same here, I did an upload, and got e-mail things are fine, but I can't access "my designs" page at all to edit it or see any of my store really.
Re: Shapeways site update of December 1st 2010 [message #21227 is a reply to message #21219 ] Fri, 03 December 2010 09:01 UTC Go to previous messageGo to next message
avatar barrys  is currently offline barrys
Messages: 116
Registered: May 2010
Go to all my models
Senior Member
I work here
There were problems with the galleries and model uploads last night after a server reboot.
This has been fixed and we're up and running again.

All models that were uploaded during that time are still in the queue and are now being processed.
Re: Shapeways site update of December 1st 2010 [message #21261 is a reply to message #21128 ] Sat, 04 December 2010 03:08 UTC Go to previous messageGo to next message
avatar dizingof  is currently offline dizingof
Messages: 1288
Registered: October 2009
Go to all my models
Senior Member
Slow processing for me too... and the model is only 16k polygons..

Confused


http://www.3Dizingof.com


Re: Shapeways site update of December 1st 2010 [message #21263 is a reply to message #21261 ] Sat, 04 December 2010 03:26 UTC Go to previous messageGo to next message
avatar Grimjier  is currently offline Grimjier
Messages: 4
Registered: May 2009
Go to my shop
Junior Member
3d viewer on a model I uploaded shows it missing parts, yet same file viewed in other programs shows up fine. Glitch related to this fix? Don't want to order a part that may come out screwy.
Re: Shapeways site update of December 1st 2010 [message #21487 is a reply to message #21128 ] Thu, 09 December 2010 20:12 UTC Go to previous messageGo to next message
avatar dizingof  is currently offline dizingof
Messages: 1288
Registered: October 2009
Go to all my models
Senior Member
Still very slow validation process...


http://www.3Dizingof.com


Re: Shapeways site update of December 1st 2010 [message #21489 is a reply to message #21263 ] Thu, 09 December 2010 23:13 UTC Go to previous messageGo to next message
avatar GHP  is currently offline GHP
Messages: 118
Registered: October 2009
Go to my shop
Senior Member
@Grimjier: If your model was non-manifold at all or had overlapping meshes that needed to be unified, Shapeways' MeshMedic will have tried to fix this for you automatically. It's possible that something got lost in the process. You may want to contact service at Shapeways about this.
Re: Shapeways site update of December 1st 2010 [message #21497 is a reply to message #21487 ] Fri, 10 December 2010 09:03 UTC Go to previous messageGo to next message
avatar hans.lambermont  is currently offline hans.lambermont
Messages: 48
Registered: June 2010
Go to all my models
Member
I work here
dizingof wrote on Thu, 09 December 2010 20:12

Still very slow validation process...


Hi Dizingof,

Your model 188158 took no less than 3681 seconds to process. Our new self-Intersection check was responsible for 3394 of those seconds.

Model 188406 took 658 seconds to process.

Model 188501 took 57 seconds to process.

So it's our new self-Intersection check causing these long delays. We'll work on this.

regards,
Hans Lambermont
Re: Shapeways site update of December 1st 2010 [message #21505 is a reply to message #21128 ] Fri, 10 December 2010 14:14 UTC Go to previous message
avatar dizingof  is currently offline dizingof
Messages: 1288
Registered: October 2009
Go to all my models
Senior Member
Great. Thanks.


http://www.3Dizingof.com



 
   
Previous Topic:Shapeways site update of December 9th 2010
Next Topic:Chasing apache segfaults