Home »  » 3D Design » Can't find Manifold Error
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Can't find Manifold Error [message #10081] Sun, 21 February 2010 02:55 UTC Go to next message
avatar gyoenastaader  is currently offline gyoenastaader
Messages: 6
Registered: August 2008
Go to all my models
Junior Member
I've used MeshLab and Blender, and neither can find the error the Shapeways checker is finding.

  • Attachment: Atsusit2.STL
    (Size: 192.07KB, Downloaded 105 time(s))

Re: Can't find Manifold Error [message #10082 is a reply to message #10081 ] Sun, 21 February 2010 04:22 UTC Go to previous messageGo to next message
avatar GHP  is currently offline GHP
Messages: 118
Registered: October 2009
Go to my shop
Senior Member
When I tried the "Remove Non-Manifold Faces" function in Meshlab, it found and removed 88 faces, after which the model was apparently manifold and free of holes. (I also had it remove duplicate vertices when opening the file.) I'm attaching the result.

Blender thought it was manifold after the removal of duplicate vertices. Blender typically removes "duplicate" vertices that Meshlab does not think are duplicates, so this may be the reason for the difference. (Although my past experience has been that Shapeways is more likely to agree with Blender than Meshlab on this.)

Re: Can't find Manifold Error [message #10088 is a reply to message #10081 ] Sun, 21 February 2010 12:45 UTC Go to previous messageGo to next message
avatar aoster  is currently offline aoster
Messages: 12
Registered: November 2009
Go to all my models
Junior Member
Hi,
I attached to model in a way that uploads fine to Shapeways.

Bye,
Alex

Re: Can't find Manifold Error [message #10095 is a reply to message #10088 ] Sun, 21 February 2010 16:37 UTC Go to previous messageGo to next message
avatar gyoenastaader  is currently offline gyoenastaader
Messages: 6
Registered: August 2008
Go to all my models
Junior Member
Thanks! Strange that Meshlab found it for you, it always reported zero for me.
Re: Can't find Manifold Error [message #10395 is a reply to message #10095 ] Wed, 03 March 2010 15:43 UTC Go to previous message
avatar dymihail  is currently offline dymihail
Messages: 53
Registered: August 2008
Go to all my models
Member
Did you try both "Non-manifold faces" and "Non-manifold vertices?" I've found that the removal of one will introduce the other, such that the other filter needs to be run again. I've also found that re-running the filter can crash the system. And that after saving, I can get more errors if I re-run either filter yet again. And sometimes it will find the same error that it claimed it had just fixed

Basically, my experience with MeshLab has been that it has some interesting features, but that it's buggy, unreliable, inconsistent and prone to crashes.

 
   
Previous Topic:How do you fix inverted normals on rhino
Next Topic:Inventing the Wheel...

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.